Cloudflare Incident

Incident Report for Keypup

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:50 UTC

Monitoring

Cloudflare has implemented a fix and is currently monitoring traffic through their network.
Posted Nov 18, 2025 - 14:51 UTC

Identified

Intermittent traffic issues are preventing users from accessing the platform. This is due to a global outage on the Clouflare side.

Cloudflare incident status page: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 14:04 UTC
This incident affected: Platform (HQ) and Data & Reporting.