Jira - Occurences of cross-project issues

Incident Report for Keypup

Resolved

This incident has been resolved.
Posted Sep 05, 2023 - 08:20 UTC

Update

All Jira projects have been resynced. We are now doing some additional monitoring before closing the incident.
Posted Sep 04, 2023 - 12:47 UTC

Update

All Jira projects have been cleaned up from unwanted issues. We are now resyncing all Jira projects from their respective Jira instance.
Posted Sep 04, 2023 - 10:35 UTC

Monitoring

A fix has been deployed to production. We have now started cleaning up the Jira projects on the Keypup side to remove unwanted issues.
Posted Sep 04, 2023 - 09:31 UTC

Update

A fix has been developed and is currently being tested by our team.
Posted Sep 01, 2023 - 12:54 UTC

Identified

We have identified the source of the issue. Some logic in our webhook processor was leading to the retrieval of arbitrary issues by ID under each Jira instance (across projects for each instance). A fix is going to be developed and deployed to correct this issue.

Once deployed we will start cleaning up the datasets to remove any unwanted issue in each Jira project on the Keypup side.
Posted Aug 31, 2023 - 16:52 UTC

Update

We are continuing the investigations. The issue is not systematic. It is currently unclear if the issue comes from the Keypup side or from the Jira side (= incorrect filtering based on project ID when retrieving issues on the API via JQL)
Posted Aug 31, 2023 - 15:32 UTC

Investigating

We are currently investigating a Jira issue where tickets from other Jira projects (not selected) may appear under selected projects on Keypup.
Posted Aug 31, 2023 - 11:01 UTC
This incident affected: Data & Reporting.